TAKO. INTERNET SEIT 1996.
Olympus-OM

Re: [OM] OM-2S Program shutter ring is stuck!

Subject: Re: [OM] OM-2S Program shutter ring is stuck!
From: "Robert T. Lewis" <rlewis@xxxxxxxxxxxxx>
Date: Sun, 18 Apr 1999 18:57:43 -0400
Cc: olympus@xxxxxxxxxxxxxxx

Henry,

I have had the same experience with my OM-2S.  I did the following to fix
it:

   Remove the ring and the underlying parts
   Clean all the parts in alcohol
   Reduce the tension slightly on the spring holding the ball in the
   detents
   Lightly lubricate the detents with white lithium grease
   Recalibrate the speed setting by comparing to the automatic mode setting

This seems to be a permanent fix, and it was pretty easy to do.  Good luck.

Robert Lewis





Henry Devereux <hldevo@xxxxxxxxxxxxx> on 04/15/99 04:30:53 PM

Please respond to olympus@xxxxxxxxxxxxxxx

To:   olympus@xxxxxxxxxxxxxxx
cc:    (bcc: Robert T. Lewis/Bellcore)
Subject:  [OM] OM-2S Program shutter ring is stuck!




Has anyone experienced a stuck shutter ring with one of the OM-series
cameras or more specifically, the OM-2S Program?  I bought one last
weekend for a very good price.  At the time of the purchase,
everything worked fine although the shutter ring was a bit more
difficult to turn than I had expected.  Having no experience with
Olympus cameras, I thought that this was typical (I shoot primarily
with EOS stuff).  Anyway, everything worked well until yesterday when
the shutter ring got progressively more difficult to turn.  Today, it
got stuck on the 1/8 sec. setting.  Is this a typical problem with OM
cameras?  If anyone has experienced this problem before, is this
something I can fix myself?  If I shouldn't attempt to repair it
myself, what should I expect to pay to have it fixed?

Aside from the stuck shutter ring, everything else works perfectly.
I've shot several rolls with it using Program, Aperture Priority and
Manual/Spot metering that all turned out perfectly.  The meter is
accurate when compared to my handheld meter and my EOS 3.

I can't return it because I bought it at a camera show out of town and
don't even know the dealer I bought it from.  I didn't ask for a
receipt because at the time it was working fine.  And for $90
including a clean 50 mm 1.8, it was well worth the risk.   Any
thoughts will be appreciated.
___________
Regards,

Henry -----> hldevo@xxxxxxxxxxxxx

< This message was delivered via the Olympus Mailing List >
< For questions, mailto:owner-olympus@xxxxxxxxxxxxxxx >
< Web Page: http://Zuiko.sls.bc.ca/swright/olympuslist.html >








< This message was delivered via the Olympus Mailing List >
< For questions, mailto:owner-olympus@xxxxxxxxxxxxxxx >
< Web Page: http://Zuiko.sls.bc.ca/swright/olympuslist.html >


<Prev in Thread] Current Thread [Next in Thread>